Author Topic: not all contacts uploading  (Read 5729 times)

jk

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
not all contacts uploading
« on: January 21, 2012, 01:15:12 AM »
I have this installed 04.0a1 but still have lots of contacts tha't are not uploading to Google. I went through and made sure all of my 1800+ contacts has either an email address or a dummy placeholder address, but it seems only about 1600 will upload to Google. I've tried everything i see on your site and with no success. Any suggestions on where my problem may be?

Josh Geenen

  • gContactSync Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 720
  • Karma: +5/-0
    • Pi Rules.org
Re: not all contacts uploading
« Reply #1 on: January 22, 2012, 01:27:36 PM »
When you started using 0.4.0 was the address book you chose to synchronize empty or did it already have some contacts (or did you move/copy your contacts there later)?

Can you try this:

1. Go to gContactSync -> Preferences and check Enable Verbose Logging
2. Restart Thunderbird (this will reset the log to make it easier to debug)
3. Open the Address Book window andright-click your address book that you synchronize and pick Replace to server.  This will tell gContactSync to re-upload every contact in the address book.  If a contact isn't being synchronized then it should be added to Google instead.
4. Sync again.  It should update or add all 1800+ contacts.

If that doesn't work please e-mail or PM me the log file.  Once you restart Thunderbird then the log starts over from scratch.  You can view the log by clicking Log under gContactSync.

Josh
gContactSync: info FAQs

jk

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
Re: not all contacts uploading
« Reply #2 on: January 22, 2012, 10:07:49 PM »
Thanks, Josh.  I did what you suggested and only 299 (of 1832) contacts transferred to  Google. I will email you the debugging results shortly. Thanks for your assistance!

jk

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
Re: not all contacts uploading
« Reply #3 on: January 22, 2012, 10:23:09 PM »
Josh - I  tried to send you the debug results, but but was timed out both on PM and email. I think the  the debug data  text is too big maybe? I don't see a way to attach the debug data as a file via the board email/PM system here.

jk

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
Re: not all contacts uploading
« Reply #4 on: January 23, 2012, 01:27:29 PM »
Josh - I just noticed that you cna add an attachemnt to foru mpst here, but am not sure if posting the debugging would inadvertently reveal any personal info on my part.

Josh Geenen

  • gContactSync Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 720
  • Karma: +5/-0
    • Pi Rules.org
Re: not all contacts uploading
« Reply #5 on: January 23, 2012, 08:50:35 PM »
Could you try using the error log submission tool?  I've received some fairly large logs that way.  The log will all your contacts in it so it isn't something you want to upload publicly.

Josh
« Last Edit: January 23, 2012, 09:08:03 PM by Josh Geenen »
gContactSync: info FAQs

jk

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
Re: not all contacts uploading
« Reply #6 on: January 25, 2012, 01:17:35 PM »
josh - i tried that but it just seems to hang. Is there any way I could just send it you via regular email? I promise not to spam you ; )

Josh Geenen

  • gContactSync Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 720
  • Karma: +5/-0
    • Pi Rules.org
Re: not all contacts uploading
« Reply #7 on: January 26, 2012, 06:35:47 PM »
Sorry I thought you said that e-mail timed out.  I sent you my e-mail address in a PM.  It's just my first and last name at gmail.com.

Josh
gContactSync: info FAQs

Josh Geenen

  • gContactSync Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 720
  • Karma: +5/-0
    • Pi Rules.org
Re: not all contacts uploading
« Reply #8 on: January 26, 2012, 09:53:18 PM »
There are a lot of characters in there that my text editor doesn't understand and it looks like Google doesn't like them either:

Code: [Select]
<atom:entry xmlns:atom="http://www.w3.org/2005/Atom">
  <atom:category scheme="http://schemas.google.com/g/2005#kind" term="http://schemas.google.com/g/2005#contact"/>
  <name xmlns="http://schemas.google.com/g/2005">
    <givenName yomi="">John</givenName>
    <familyName yomi="">Doe</familyName>
  </name>
  <email rel="http://schemas.google.com/g/2005#other" address="[b] (invalid characters) zzz@null.com[/b]" xmlns="http://schemas.google.com/g/2005"/>

Code: [Select]
An invalid XML character (Unicode: 0x{2}) was found in the value of attribute &quot;{1}&quot; and element is &quot;b&quot;.
Please report this error to gcontactsync at pirules.org (in English, if possible)

It looks like gContactSync found 1832 contacts during the initial sync and tried to add them, but got that error on most of its attempts to add contacts.  The summary still showed that it added 1832 contacts, but it didn't (I need to fix that).  The status bar on the bottom right corner at least should've said " Error during sync. Click here to view the log."

I haven't been able to recreate this with the unicode characters I've tried.  Can you copy and paste one of those fake e-mail addresses in a reply?  If it won't let you could you try e-mailing one to me?
gContactSync: info FAQs

jk

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
Re: not all contacts uploading
« Reply #9 on: January 26, 2012, 10:27:32 PM »
The fake address I used to filled in for all contacts w/o email addresses was zzz@null.com

So do you think that is the issue?

Josh Geenen

  • gContactSync Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 720
  • Karma: +5/-0
    • Pi Rules.org
Re: not all contacts uploading
« Reply #10 on: January 26, 2012, 10:34:31 PM »
Weird, because the log definitely shows some invalid characters before the zzz.  How did you add these email addresses?

Also, mailing lists in Thunderbird require a unique email address for each contact.  I wouldn't put it past a mailing listbug to add those characters...

Josh
gContactSync: info FAQs

jk

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
Re: not all contacts uploading
« Reply #11 on: January 26, 2012, 10:50:38 PM »
The contacts come from a CSV that I imported into Firebird.  I did an "Edit-Fill-Down" and added the fake addys before importing it all into Firebird. The CSV was originally exported from a Filemaker database I have used for 10 years to track my contacts.

If FB requires unique email addresses and I have 100s and 100s of contacts w/o an email address, how would I get past the issue that Gmail would require an email address?
« Last Edit: January 26, 2012, 10:57:22 PM by jk »

jk

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
Re: not all contacts uploading
« Reply #12 on: January 26, 2012, 10:54:35 PM »
BTW, I just re-checked the original CSV file and there does NOT appear to be anything in the email address field before the zzz@null.com

Josh Geenen

  • gContactSync Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 720
  • Karma: +5/-0
    • Pi Rules.org
Re: not all contacts uploading
« Reply #13 on: January 26, 2012, 10:59:45 PM »
So it sounds like the editor may have inserted those invalid characters then (they might not visible). If possible could you take the original CSV and import it, or have you made too many changes? I could write a script to fix them otherwise, but I might not have time until Saturday.

Google doesn't require an email address but mailing lists in Thunderbird do if you use them to sync with groups.  gContactSync will add a fake email address itself if necessary. Just make sure you organize your contacts into groups through Gmail only.

Josh
gContactSync: info FAQs

jk

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
Re: not all contacts uploading
« Reply #14 on: January 26, 2012, 11:03:23 PM »
Sorry, but I'm not understanding where you are saying to import the original csv to - FB? Gmail?

And thanks again for your help untangling this issue.